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Updating “Using Autodesk Inventor” to Release 5

Appendix R5–1
Introduction

Chapter 1 outlines the concepts of parametric solid modeling, assembly modeling, and
engineering drafting. It also provides a brief introduction to Inventor and familiarizes you
with the design support system that helps you while you are designing. This appendix
complements Chapter 1 by delineating the following features in Autodesk Inventor 5:

⇒ Application Programming Interface

⇒ Design Support System

⇒ Interoperability

⇒ Design Management

⇒ Third Party Partner Applications

⇒ 3D Standard Parts

Application Programming Interface
In R5, you can use Microsoft’s Visual Basic for Applications (VBA) to access Autodesk Inventor’s
application programming interface (API) to construct programs to perform the following tasks:

Tasks Functions

Sketches For constructing and editing sketches, including sketch
plane, sketch geometry, and geometric and dimension
constraints

Features query and construction For querying and constructing extruded, revolved, hole,
pattern, and work features

Dynamic attributes For attachment of data to object

Assembly constraint construction For querying and constructing assembly constraints

Printing For automating printing process

Data exchange For translation of data to various formats

User selection and mouse events For selection of objects

Custom graphics For construction of graphics by using external applications

Highlighting graphics For highlighting objects in the graphics window

Additional browser tab For adding tabs to the browser

Transactions For nesting of transaction in a single operation
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Tasks Functions

Selection set For objects selection using the Select command

Render styles For accessing rendering styles

Part materials For accessing and modifying all the existing material
definitions and construction of new materials

Menu customization For constructing new menus custom sub menus

Design Support System
The Design Support System (DSS) has a  number of components: Help System, Autodesk On-line, What’s
New About Autodesk Inventor, Visual Syllabus, Design Professor, Design Doctor, and Sketch Doctor. In
R5, it has several enhancements:

Help for AutoCAD Users
R5 includes a set of help topics to help AutoCAD users migrate to Autodesk Inventor. These help topics are
available in the Getting Started dialog box and the Help Topics dialog box. To learn migrating from
AutoCAD to Inventor by using the Getting Started dialog box, perform the following steps.

1. Select Getting Started in the Open dialog box. (See Figure 1–1.)
2. In the Getting Started tab of the Open dialog box, select Learn about AutoCAD

to Inventor Help. (See Figure 1–2, the Get to Know Inventor dialog box.)
3. Close the dialog box after reading the dialog boxes.

Figure 1–1
Getting Started
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Figure 1–2
Get to Know Inventor dialog box

To learn migration by using the Help Topics dialog box, perform the following steps.

1. Select New from the Open dialog box and start a new part file.
2. Select Help Topics from the Standards toolbar. (See Figure 1–3.)
3. Select Help for AutoCAD users.

Here you will find several useful links:

⇒ Welcome to Inventor

⇒ Show me Inventor

⇒ Use AutoCAD data

⇒ Frequently asked questions

⇒ Command map
4. Close the Help Topics dialog box after reading the linked pages.
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Figure 1–3
Help Topics dialog box

Support Assistance
The support assistance provides technical support information about Autodesk Inventor and other resources.
To find out the new enhancements in the Support Assistance, perform the following steps:

1. Select Support Assistance Help from the Help pull-down menu. (See Figure 1–
4.)

In the Contents tab of the Autodesk Inventor 5 Support Assistance dialog box, you will find two support
topics: Welcome and Solution index.

2. Expand the list in the Content tab to find out what kind of support assistance
are available.

By using the Support Assistance, you learn the following topics:

⇒ Customization

⇒ Documentation

⇒ Error Messages

⇒ Features and Commands

⇒ Installation, Configuration, and Performance

⇒ Interoperability/File & Data Translation
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Figure 1–4
Selecting Support Assistance from the Help Topics dialog box

3. Close the dialog box after reading.

Programming Help
In R5, the Autodesk Inventor Application Programming Interface reference guide is accessible from the
Help pull-down menu. The programming help includes objects, methods, properties, events, and enums. To
read the API reference guide, perform the following steps:

1. Select Programming Help from the Help pull-down menu. (See Figure 1–5.)
2. Close the reference after reading.

Figure 1–5
Inventor API Reference
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Interoperability
Apart from opening and saving the four kinds of Inventor files (Part file, assembly file, presentation file,
and drawing file), you can open various kinds of file formats in Autodesk Inventor and export Inventor files
to various file formats.

Open
You can open the following file formats:

⇒ AutoCAD Drawing (*.dwg)

⇒ DXF (*.dxf)

⇒ IGES (*.igs, *.ige, *.iges)

⇒ Pro/Engineer File (*.prt*, *.asm*)

⇒ SAT (*.sat)

⇒ STEP (*.stp, *.ste, *.step)

Save As
You can save an Inventor part file to:

⇒ BMP (*.bmp)

⇒ IGES (*.igs, *.ige, *.iges)

⇒ SAT (*.sat)

⇒ STEP (*.stp, *.ste, *.step)

⇒ STL (*.stl)

⇒ Streamline Part Packages (*.ptp)

⇒ XGL Files (*.xgl)

⇒ ZGL Files (*.zgl)
You can save an Inventor drawing file to:

⇒ Drawing Files (*.dwg)

⇒ DXF (*.dxf)

⇒ BMP (*.bmp)

⇒ Drawing Web Format (*.dwf)

⇒ Streamline Drawing Packages (*.dwp)
You can save an Inventor Presentation file to:

⇒ BMP (*.bmp)
You can save an Inventor assembly file to:

⇒ BMP (*.bmp)
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⇒ IGES (*.igs,  *.ige, *.iges)

⇒ SAT (*.sat)

⇒ STEP (*.stp, *.ste, *.step)

⇒ Streamline Assembly Packages (*.amp)

⇒ XGL Files (*.xgl)

⇒ ZGL Files (*.zgl)
In R5, major enhancement on interoperability concerns AutoCAD and Mechanical Desktop files. When you
open a .dwg file, the open wizard will automatically determine whether the file is an AutoCAD file or a
Mechanical Desktop file and provides appropriate options accordingly. To open a Mechanical Desktop file,
perform the following steps:

1. Select Open from the File pull-down menu.
2. In the Open dialog box, select a Mechanical Desktop file and select the

Options button. (See Figure 1–6.)

Figure 1–6
Opening a Mechanical Desktop file

3. In the Read DWG/DXF File dialog box, select the Mechanical Desktop File
button and select the Next button. (See Figure 1–7.)

4. In the Read MDT File — Select Model Translation and Drawing Layout dialog
box, check the Translate Parts and Assemblies button and select the Next
button. (See Figure 1–8.)
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Figure 1–7
Read DWG/DWF File — Choose Document Type dialog box

Figure 1–8
Read MDT File — Select Model Translation and Drawing Layout dialog box

5. In the Read DWG/DXF File — Choose Destination dialog box, set the Part
Options, select a destination directory, and select the Finish button. (See
Figure 1–9.)

The selected Mechanical Desktop drawing is opened and converted into an Autodesk Inventor file. (See
Figure 1–10.)
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Figure 1–9
Read MDT/DXF File — Choose Destination dialog box

Figure 1–10
Mechanical Desktop file opened

You can save an Inventor drawing file to an AutoCAD file by performing the following steps:

1. Select Open from the File pull-down menu.
2. Select an Autodesk Inventor drawing file. (See Figure 1–11.)
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Figure 1–11
Autodesk Inventor drawing file

3. Select Save Copy As from the File pull-down menu.
4. In the Save Copy As dialog box, select AutoCAD Drawing (*.dwg) from the

Save As Type pull-down box and select the Options button. (See Figure 1–12.)

Figure 1–12
Save Copy As dialog box

5. In the DWG File Export Options dialog box, select file version, set options, and
select the Next button. (See Figure 1–13.)

6. Select appropriate properties from the Available Properties list box and select
the Add button.

7. Select the Next button. (See Figure 1–14.)
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Figure 1–13
DWG File Export Options dialog box

Figure 1–14
Parts List Properties Export Options dialog box

8. In the Layers Export Mapping dialog box, select the Finish button. (See Figure
1–15.)

The Autodesk Inventor drawing file is converted to an AutoCAD drawing. Figure 1–16 shows the converted
file opened in AutoCAD.
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Figure 1–15
Layers Export Mapping dialog box

Figure 1–16
AutoCAD drawing converted from an Autodesk Inventor drawing file
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Design Management
Design management tools help you manage your design. There are several enhancements in R5.

Design Assistant
There are two ways to use the Design Assistant: Select Design Assistant from the File pull-down menu or
select a file in the Windows Explorer, right-click, and select Design Assistant. (See Figure 1–17.)

The left pane of the Design Assistant dialog box has three buttons: Properties, Preview, and Manage. Figure
1–18 shows the properties of the selected assembly file.

To view a component without opening it in Autodesk Inventor, you select it from the Design Assistant,
right-click, and select View. (See Figure 1–19.)

Figure 1–17
Using Design Assistant from the Windows Explorer

Figure 1–18
Properties of an assembly file in the Design Assistant
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Figure 1–19
Selecting View in the right-click menu

In the Viewer shown in Figure 1–20, you can zoom, pan, and rotate the display of the component.

Figure 1–20
Viewer

To view the components quickly in preview images, you can select the Preview button in the Design
Assistant. (See Figure 1–21.)
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Figure 1–21
Preview

To manage the component files of an assembly, you select the Manage button. (See Figure 1–22.) To search
for the files that reference the specified file, you select Where Used from the Find cascading menu from the
Tools pull-down menu. (See Figure 1–23.)

Figure 1–22
Managing files in the Design Assistant
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Figure 1–23
Where Used dialog box

By selecting a component and right-click, you select Properties and discover the properties of the selected
component. (See Figure 1–24.)

Figure 1–24
Properties
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Pack and Go Wizard
Using the Pack and Go wizard, you package a set of Inventor files in a project and all of its referenced files
in a single location. You can access Pack and Go wizard by using the right-click menu from the Windows
Explorer or Design Assistance. (See Figure 1–17 and Figure 1–24.) In R5, you can create complete
document sets of a given assembly. The Pack and Go dialog box is shown in Figure 1–25.

Figure 1–25
Pack and Go dialog box

Volo View
Volo View is a design viewing application that enables you to view files constructed by using Autodesk
Inventor 5 and AutoCAD 2002. Figure 1–26 shows an Inventor file viewed in Volo View application. By
using the Volo View application, you view, mark up, and print Inventor files.
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Figure 1–26
Volo View application window

Third Party Partner Applications
In a computerized manufacturing system, you use various computer-aided tools in addition to computer-
aided design tools. Listed below are a number of companies providing applications that work with Autodesk
Inventor.

Power Piping
Power Piping is a product of CAD Management Group, Inc. It provides fully parametric Autodesk Inventor
solid parts for dragging and dropping into an Inventor assembly. Figure 1–27 shows the website of the
company.

Figure 1–27
Power Piping product
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Design Space Product
DesignSpace is a product of Ansys, Inc. Using Design Space product, you set up and simulate your
assembly designs and communicate your results with the rest of your company. Figure 1–28 shows the
website of the company.

Figure 1–28
Design Space product

visualNastran 4D
visualNastran 4D is a product of MSC. Working Knowledge. This product provides motion and FEA
(Finite Element Analysis) simulation on Autodesk Inventor assemblies. Figure 1–29 shows the product’s
website.

Figure 1–29
visualNastran product
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COSMOS/DesignStar
COSMOS/DesignStar is a product of Structural Research and Analysis Corp. It is a design analysis tool that
is fully associative with Autodesk Inventor. Changes in either application automatically update the other.
Figure 1–30 shows the product’s website.

Figure 1–30
COSMOS/DesignStar

EdgeCAM Solid Machinist
EdgeCAM Solid Machinist is a product of Pathtrace, Inc. It is a CNC programming system. Figure 1–31
shows the company’s website.

Figure 1–31
EdgeCAM Solid Machinist
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CADVerter
CADVerter is a product of Theorem Solutions, Ltd. Using CADVerter, you convert STEP files generated
from Autodesk Inventor to various CAD file formats. (See Figure 1–32.)

Figure 1–32
CADVerter

AutoManager Meridan
AutoManager Meridan is a product of Cyco Software. It is a document management application. Figure 1–
33 shows the company’s website.

Figure 1–33
AutoManager Meridian
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SmartInventor
SmartInventor is a product of Smart Solution, Ltd. It is a product data management application for Inventor
files. Figure 1–34 shows the product’s website.

Figure 1–34
SmartInventor

3D Standard Parts
Use of standard parts and components largely reduces the time to complete a design. Standard parts
constructed in Autodesk Inventor, AutoCAD, and 3D Studio Viz formats are available from many leading
suppliers of standard parts in the form of iDrop parts. You select the standard iDrop parts from the supplier
and drag them to your design. To install iDrop in your computer, you may visit the Autodesk iDrop website
(http://iDrop.Autodesk.Com). (See Figure 1–35.)

Figure 1–35
iDrop
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You can access standard Inventor parts from Redspark catalogs. Figure 1–36 shows the website of
www.redspart.com. To obtain updates and access to supplier parts, you can go to Autodesk point A website.
(See Figure 1–37.)

Figure 1–36
Redspark — Supply chain source for engineering

Figure 1–37
PointA — Online design resource and community portal


